logi-projects repository

The wishbone app. doesn't work out-of-the-box from the repository i.e., using Xilinx ISE.
It does work as installed from the latest image.
I'm totally new to all this stuff including all the tools, languages, Beaglebone and FPGAs (I'm comfortable with Linux and vaporware-like stuff).
But after much head scratching I hacked up the .ucf declaration in the logibone .xise file to look like the one in the logipi .xise (its missing an  "association" statement) and Voila! Everything works as advertised.

I'm just wondering if I did the right thing (all of this is like Creole to me).


  • Hi,

    i'll have a look at the project and see what can be wrong. At some point we worked on getting the wihsbone app working with SPI on the Logi-bone instead of GPMC and that is maybe where things were broken. Thanks for your feedback.
  • Thanks! I appreciate the help.
  • Hello all,
    i am trying also .xise project of wishbone and when i opened the project it was asking for gpmc2wishbone - gpmc_wishbone_wrapper. I found the file in logi-hard-master.

    The project now makes the .bit file but in my LogiBone the Led does not operates as in the predefined example.

    My question is (i am sorry if it is a silly question) there is no .ucf file in the project. Do i have to include a .ucf file?

    I tried with different .ucf files from the logi-hard-master folder but when i try to compile the project i get these errors:

    1. The specified design element actually exists in the original design.
    2. The specified object is spelled correctly in the constraint source file.

    Could you post the .ucf file that you used?

    Also i want to ask which the max speed that i can get data at the BeagleBoneBlack from the LogiBone through wishbone?

    Thank you very much,


  • I am using ISE 14.7 and can not get logi-wishbone for logibone to work.  It builds with a few warnings, but access from the BBB does not work at all.  I tried rolling back the versions of logi-hard and logi-project back to 2014, but was unable to get it to work.  As stated above, the version of the bit file that was installed when I setup the Ubuntu distribution on my BBB works.  Has anyone found a set of corrections that will work?
  • Hmm, I just used git clone to pull everything again instead of downloading zip file versions,  changed the UCF file to the r1 version, and the register reads and writes started working, but the PWM output to the LEDs isn't working.  At least that is one step forward.
  • Arrgh, there is a typo in the README.TXT file that has a letter "O" in the address of the duty cycle register 0x9.
Sign In or Register to comment.