Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

RPI2

Hi, I have just got my RPI2, and starting with a fresh install. I have downloaded the latest Raspbian image, and have cloaned the GIT to get the updated tools. But the build fails.

I get a message saying

gcc: fatal error: no input files

And further down recipe for target 'serial_fpga_loader.o' failed

If I ls the folder I can't see serial_fpga_loader.o

Is this missing from the GIT?

Mark

Comments

  • Accepted Answer
    Hi,

    i just corrected a bug in teh loader coe that was updated for PI2, can you do a gill pull on logi-tools ? For the PI2, there are multiple things to do before eveyrthing works :

    1) to a clean in stall of latest logi-tools
    2) go in the logi-tools/logipi_loader directory
    3) do a  "make clean" followed by a "make PI_VER=PI2" and finally "sudo make install"
    4) got to the /boot directory of your PI, and edit the config.txt file
    5) add the line "device_tree=" to disable device_tree and reboot

    At this point everything should be working fine.

    Regards,

    Jonathan Piat
  • Yes that worked fine. Can you update the readme on the GIT to include the above?
  • I followed the instructions, but I am having problems getting Raspberry Pi 2 working with LOGi Pi2. The error I get is

    LOGI_LOADER VERSION : 0.1.0
    Compiled for LOGI-PI
    could not open I2C device : /dev/i2c-1!
    Cannot detect LOGI-PI with I2C_LOADER, switching to old bit-bang loader
    Board variant is LOGIPI_R1.0
    can't open /dev/mem
    Blink LED App *************************************************************************

    I'm using the latest image from the wiki logi_2015-02-16-raspbian-wheezy. I did a git pull to make sure I had the latest code for logi-tools.

    thanks
    logi-pi-error.png
    1083 x 488 - 37K
  • DI you follow these instructions on the github :

    To enable SPI on latest raspbian distro, edit /boot/config.txt (as sudo) and add :

    dtparam=spi=on

    To enable I2C on latest raspbian distro, edit /boot/config.txt (as sudo )and add :

    dtparam=i2c_arm=on

    to the file.

    also edit /etc/modules (as sudo) and add the line :

    i2c-dev

  • I used the image up on the wiki and double checked all of that. I saw the other thread and contacted element14 to get a replacement.
  • edited March 15
    I'm one more person who has this problem.   I'm running on an original Raspberry Pi, not a Pi2.

    I'm using the stock logi_2015-02-16-raspbian-wheezy.img
    i've done a git pull (it was up to date)
    I can see the right lines in /boot/config.txt  and /etc/modules
    I've make and installed the unified loader
    I've rebooted many times

    I still get:

    root@logipi:/home/pi/logi-apps/blink_led_app# /home/pi/logi-tools/unified_loader/logi_loader
    Compiled for LOGI-PI 
    could not open I2C device : /dev/i2c-1!
    Cannot detect LOGI-PI with I2C_LOADER, switching to old bit-bang loader 
    Board variant is LOGIPI_R1.0 

    That is, I can't open /dev/i2c-1 so nothing else stands a chance of working.

    I'm disappointed, I was looking forward to playing with this but instead I've spent a whole day of holiday trying to get it to run "hello world" (and I've scheduled much mroe time to learn Verilog/VHDL).
Sign In or Register to comment.