Antenna switching extension and V1.141 [must use Oct 29, 2017, or later, antenna switch extension]

Has anything changed in version 1.141 that affects antenna switching? My kiwiSDR does not change antennas any more. Have tested rebooting.

Regards

Mauritz / SM2BYC

Comments

  • I have broken the antenna switching extension in the past when I make big API changes. But I tested it and it seemed okay. I just checked http://szsdr.ddns.net:8073 who runs v1.141 and has 5 different antennas and it seems to work fine.

    If you bring up the Javascript console window of the browser do you get any error messages when the extension is used? Does changing the antenna switch settings on the admin page still work?

  • Changing the antenna switch settings on the admin page works. Any change there is reflected on the main screen when the antenna switch extension is in use. When I try to select an antenna, the antenna field only stays green as long as the mouse button is pressed. No antenna switching takes place when clicking on different antennas.

    Have never before used the Javascript console window, so I am not sure how to spot error messages. Could not see anything obvious when testing the antenna switch.

    Regards

    Mauritz / SM2BYC
  • Accepted Answer
    Hi Mauritz,

    I have just updated my KiWi with antenna switch to V1.141and it works OK.

    Just a thought - have you upgraded to the most recent version of switch extension ?


    The latest version has a new initialisation script for the GPIO ports.

    Unfortunately it's a bit of a pain to install as the uninstaller doesn't remove any existing KiwiSDR-antenna-switch-extension directory.

    I had to follow these steps to upgrade to the latest version, the whole process takes about 30 minutes to complete.

    cd /root
    cd KiwiSDR-antenna-switch-extension
    bash ./ant-switch-extension-uninstaller
    cd /root
    rm -r KiwiSDR-antenna-switch-extension
    cd KiwiSDR-antenna-switch-extension
    bash ./ant-switch-extension-installer

    Regards,

    Martin - G8JNJ

  • jksjks
    Accepted Answer
    I have found this: If you are not using the latest antenna switch version with the October 29 commit then you get the problem with the antenna select buttons not staying green. I don't understand what this has to do with v1.141 though.

  • Hi Martin,

    I have not yet updated to the most recent version of the antenna switch extension. Will try to update as soon as there are no users connected. Thanks for the step-by-step guide.

    Regards

    Mauritz / SM2BYC

  • Updated to the latest version of the antenna switch extension and now it works again. Martin and John: thanks for your help!

    Regards

    Mauritz / SM2BYC

Sign In or Register to comment.