Python script kiwifax.py [script requires more recent Kiwi server version]

I was able to successfully connect using my browser.
I was trying to execute, kiwifax.py and received this error:

yan@UbuntuYan:~/Downloads/kiwiclient-jks-v0.1$ python2 kiwifax.py -s 192.168.5.1
20171011T1532Z CRITICAL: * * * * * * * *
20171011T1532Z CRITICAL: Logging started
Traceback (most recent call last):
File "kiwifax.py", line 755, in main
recorder.run()
File "/home/yan/Downloads/kiwiclient-jks-v0.1/kiwiclient.py", line 273, in run
received = self._stream.receive_message()
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_hybi.py", line 751, in receive_message
frame = self._receive_frame_as_frame_object()
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_hybi.py", line 456, in _receive_frame_as_frame_object
opcode, unmasked_bytes, fin, rsv1, rsv2, rsv3 = self._receive_frame()
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_hybi.py", line 453, in _receive_frame
unmask_receive=self._options.unmask_receive)
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_hybi.py", line 192, in parse_frame
received = receive_bytes(2)
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_hybi.py", line 448, in _receive_bytes
return self.receive_bytes(length)
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_base.py", line 159, in receive_bytes
new_read_bytes = self._read(length)
File "/home/yan/Downloads/kiwiclient-jks-v0.1/mod_pywebsocket/_stream_base.py", line 119, in _read
(length, (self._request.connection.remote_addr,)))
ConnectionTerminatedException: Receiving 2 byte failed. Peer ((('192.168.5.1', 8073),)) closed connection

Thank you

Comments

  • jksjks
    edited October 11
    Well, I don't know. It works fine for me. Are you sure you got a copy of my current branch kiwiclient-jks-v0.1 ?
    The easiest way to do this is to go to https://github.com/jks-prv/kiwiclient then under "branch:" select "jks-v0.1" and then under "clone or download" use "download zip".

    Can you connect to a network Kiwi? e.g.
    python2 kiwifax.py -s kiwisdr.sk3w.se

    The error looks like the Kiwi closed the python read connection immediately. Does the Kiwi at 192.168.5.1:8073 work with a browser?

  • Yes I'm v.1 yan@UbuntuYan:~/Downloads/kiwiclient-jks-v0.1

    Yes browser works for 192.168.5.1:8073. Using python 2.7. I also tried 2.6.
  • Maybe the author of the script has an idea. I am not a python expert myself.

  • Thanks... It worked for "kiwisdr.sk3w.se." It's just having issues with recognizing ips. I'll try create a hostname.
  • I figured it out. My local kiwi didn't update because it wasn't connected to the internet. I connected the to internet, kiwi updated. Everything works.

    Thanks!
  • Ah, okay. That python code depends on a more recent version of the Kiwi server API. It should probably fetch the version number and complain if the API is incompatible. Seeed still ships Kiwis from the factory with v1.2 installed I believe.

  • > jks > Ah, okay. That python code depends on a more recent version of the Kiwi server API. It should probably fetch the version number and complain if the API is incompatible. Seeed still ships Kiwis from the factory with v1.2 installed I believe.

    Yes, 1.2 is what I received last week.

    It was a bit confusing to me because the first thing it did was update and during that time the inability to connect to it was confusing. Finally, I got a message saying it was updating, I just let it run, but the many times I tried before just resulted in no connection, leaving a first time user thinking things weren't working, even though my router showed its IP address, so I knew the connection was good.

    Perhaps if I understood what the blinking LEDs were telling me... At least I knew it was doing something.

    But since it finished updating, I have been really happy with it!


Sign In or Register to comment.