v1.99 Console

The new console tab allows you to control a Beagle Debian shell
directly from the admin page. This is an alternative to using SSH or
PuTTY to login to the Beagle. It of course requires that the Kiwi
server is successfully running

A great feature!!  Thanks

Comments

  • jksjks
    edited July 1
    It needs some work. The separate input field currently has no shell line editing or ^C processing which is a big problem. But the general idea is there. Should hopefully make debugging a little easier.


  • edited July 1
    HI OV indicator stays always ON under 1.99 ... sri seems ok
    :)]
  • edited July 1
    RESTORE PASSBAND = ok the way back but what about keeping it from previous session ?
    more : if for error the right menu is pressed going out of it moves the tuned freq....
    there should be a point over the menu to go out without affecting the freq
    ... aha... found the go-out in a blank corner of the right window menu
    Phil
  • jksjks
    edited July 1
    Hi Phil.

    When the right menu is open you can cancel it by pressing the escape key. Or, like you say, clicking in an area of the menu where no selection in blue appears. Like in the corners or the divider between sections. I'll think about making it so a click outside the menu does a cancel but is also then ignored, i.e. doesn't change frequency or whatever.

    I think storing the passband adjustment across sessions should not be the default behavior. But be enabled by one of the "user preferences" that are hopefully available soon. If a new user messes up the passband of, say, the AM mode, then disconnects, it could be very confusing what's going on when they connect again to that particular Kiwi. By by putting it in a preference you could prevent that situation. Also, you could have a preference that specifies the passbands to be used on all Kiwi connections. So you wouldn't have to adjust it for each Kiwi you connected to. This would be very nice I think.

  • having the console open at ~root/Beagle... etc would be handy at a minmum
  • Yeah, I'm having trouble getting bash to behave properly as a "login" shell (e.g. reading /etc/bash.bashrc) and other things. Already I had to manually set $TERM and $HOME and do some things to prevent the ls and grep commands from sending colorized output via ANSI escape sequences.

Sign In or Register to comment.