Problem with update to 1.95 and beyond [ant-switch extension needed update]

Hi John,

I haven't been able to run V1.95 onwards.

After problems with previous upgrades stopping the functioning of the switch extension (unless I manually reboot the Beagle to reinitialise the EXIO ports) I now leave my second private KiWi on auto upgrades and leave my public one to upgrade manually once I know that the new version is good on my private one.

It downloads the update all OK but then just sits in a loop compiling over an over again. I can see this when I log into the KiWi main page as it gives the message compiling # XX but never finishes. Sometimes it reads 28 or 30 and then the next time I check it's back to 4. The main log shows nothing obvious.

My private Kiwi is now on V1.77 as I reflashed it from an earlier backup card image. Once I had done this and verified it was OK, I retried manually reloading the latest version but it got stuck again.

Regards,

Martin - G8JNJ




Comments

  • Unfortunately, the antenna switch extension requires an update for v1.95 and beyond. On the Beagle do this:

    cd /root/KiwiSDR-antenna-switch-extension
    git checkout
    git pull -v
    cd /root/Beagle_SDR_GPS
    up

    Should be okay after that.


  • Hi John,

    OK - I wan't sure if it was due to the Ant- Switch extension as others with the extension running were shown as upgraded on sdr.hu.

    I tried pulling the git file as suggested but that didn't work as I had modified some of the ant-switch defaults.

    So I un-installed and reinstalled the Ant- Switch extension from scratch and all is now OK again.

    Thanks,

    Martin - G8JNJ
  • I haven't used it much. But I guess this means the ant-switch needs to store its configuration parameters outside of the source code distribution (like the Kiwi code does) so you can pull a new version and not have conflicts that need to be resolved.

Sign In or Register to comment.