New KiwiSDR not showing on sdr.hu [ISP port blocking or router firewall filtering?]

edited March 25 in KiwiSDR Discussion

Hello all, if this is the wrong place to ask this question
please tell me where to post.

 

I have a new KiwiSDR delivered yesterday.  I put it together, updated the software to
the latest version, and have good local connection and control.  I own several other SDRs and got this one primarily
to allow other users to have remote access. 
My intent is to configure this for 3 public and 1 passworded user.

 

However I cannot get the SDR to show up on sdr.hu.

 

I have configured as per the "Network
Configuration" on the Quickstart page.

 

Local IP of the KiwiSDR set to Static and a non-conflicting
Local IP assigned.

Port forwarding of the router set to forward port 8073 to
the static Local IP assigned to the KiwiSDR, also "Both" selected so
that TCP and UDP are included.

I do not have a domain name assigned, so I used my Public IP in the "server domain name or IP address".

"Display your KiwiSDR on sdr.hu?" has the "Yes" button selected (green).

The API key has the Registration I received from sdr.hu.

 

Using the scanner at 
http://kiwisdr.com/scan ; detects
my KiwiSDR on the right internal IP and port.

 

Under the Admin page on the Log tab, I see "sdr.hu
registration: WORKED".

 

When the above did not work I DMZed the Local IP assigned,
still no connection, or at least not showing, on sdr.hu.

 

When I connect using my Local IP:8073 I connect we.., when I
try to connect using my Public IP:8073 the connection times out.

 

I am not very network fluent, but if anyone has any ideas where
to look from here I would appreciate hearing them.

 

Thanks,

 

T!

Comments

  • What is your public IP?

    Ron - KA7U
  • Sent via PM.  Yeah, I know it will be out there on the sdr.hu web page eventually, but why get it out there too early?  ;)

    T!
  • Hey Token. Very nice to see you here. Thanks for being a Kiwi owner. Your location is valuable to me personally for some stuff I want to monitor.
    Please PM me the pub IP also. There is some stuff I can check from here (hopefully).

    Best regards,
    John, ZL/KF6VO
    KiwiSDR designer
    Tauranga, New Zealand

  • Sent.

    T!
  • (I'll post here instead of PM since it might help others)

    Pretty sure this is a router / Internet connection issue. Your Kiwi successfully registered on kiwisdr.com (to support the backup listing on kiwisdr.com/public). But it doesn't respond at all to incoming connection attempts. Both sdr.hu and kiwisdr.com must be able to get some additional information via an incoming connection before your Kiwi is listed. From a Linux machine you can do something as simple as a "curl <ip address>:8073/" and there is no response. So something is not right.

    Are there additional settings on your router besides the NAT rules that might have to be adjusted? Like a global firewall setting? Obviously when the connection attempt originates within your local network the response from the public Internet device is getting correctly mapped by the NAT. It's just that unsolicited connection attempts that originate from the public side of the router are ignored. This seems like a firewall issue to me.

  • Interesting.  Right now I have the static Internal IP of the KiwiSDR DMZed in the router.  I would think that would pretty much bypass any local firewall issues.  I wonder if my ISP filters that particular port?

    T!
  • Possibly.

    I got no response as well on port 80 so it seems you're not running a web server. So you could try running the Kiwi on port 80 instead of 8073 and see what happens (a lot of people do so they can use a Kiwi URL without a port specification). Change to port 80 on the Network tab of the admin page and restart the server. Then check by reconnecting locally on port 80 (or using no port in the URL -- your browser will default to trying port 80). Then change your NAT rules to use port 80 instead.

  • OK, now the Kiwi is DMZed in the router and it is also set to Port 80.

    T!


  • And still cannot be connected.

    Further, I went to canyouseeme.org and used the open port check tool.  No matter what port I selected and set up no port was seen as open.

    I am thinking this must be an ISP thing.

    T!

  • Still no response here. I would look at your ISPs support FAQ and see what their policy is on incoming connections for the type of service plan you have. Seems really regressive though. These kinds of incoming access problems (with the possible exception of email servers) stopped being an issue some time ago.

  • jksjks
    edited March 25
    This issue brings up a long standing question I've had. I should probably start a new topic because I think there are people on here who understand about these issues. "Why can't the Kiwi be like Skype? People can ring me on Skype and I don't need to do anything with NAT and/or the firewall on my router to let the connection in!".
Sign In or Register to comment.