Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Problem listing receiver on sdr.hu

edited December 2016 in KiwiSDR Discussion
I used to use my Raspberry Pi3 & RTL-SDR on sdr.hu, it was always listed via IP address. Since I now have a KiwiSDR I wish to use my free http://ma3101swl.ddns.net address but for some reason it is not getting listed on sdr.hu even though the link is accessible from the net and all relevant ports are open.
I'm probably missing something simple.

Any help would be appreciated!

Thanks

Neil


Comments


  • sdr.hu
     security requirements:
    For security reasons sdr.hu requires that the domain name you use (if any) must resolve to the same source IP address as registration traffic coming from the Kiwi. This is usually the case. But a few users have encountered problems when unusual dynamic DNS or VPN configurations are used and the IP addresses are different. 

    It looks like you have http://ma3101swl.ddns.net set to resolve to an IP belonging to noip.com with port forwarding (80 to 8073). But that means when you try and use this domain with sdr.hu it does not match the public IP of the Kiwi (your firewall public IP), and sdr.hu doesn't allow this. If you want it so the URL ma3101swl.ddns.net works with the Kiwi and not ma3101swl.ddns.net:8073 then don't do port forwarding. Instead change the NAT external port on your firewall from 8073 to 80 while keeping the internal port mapped to 8073. 
  • Excellent thanks, will look into that in the morning.
  • I'm still tearing my hair out with this.

    When ever I enter a url in the "Server domain name or IP address (e.g. kiwisdr.my_domain.com)" box and press enter or go into another box the domain resets back to "kiwisdr.example.com"

    Any idea?

    Thanks
  • I have managed to fix the issue with the web url not saving but still unable to get listed on sdr.hu

    Not really sure whether its router settings or domain name forwarding settings that are causing me issues, even tried a different domain name and still not working.

    I was able to access the rx from the net on either port 80 or 8073, port forwarding disabled and enabled, even have the kiwi in a dmz on router.

    I really am missing something simple here as I have never had issues with accessing anything before externally.
  • Could you login to the Beagle as root and check the log for any error message from sdr.hu ?

    Use PuTTY or ssh to root@<ip or hostname of kiwi>, no password set by default
    "cdp" to change to server build directory
    "ms" to dump log
    Look for a message like this:

    Dec 13 17:41:02 grn kiwid[9018]: 0:00:07 ....      sdr.hu registration: WORKED

    or one that says "FAILED: <error reason>"

    nionios
  • trying to change the web url ...no change.. i have logged to beagle as root looking for the log says FAILED error for example.kiwisdr.com does not resolve.....to my ip address

    please help

    thanks in advance

  • jksjks
    Accepted Answer
    nionios: I'm sorry, I don't understand exactly what error you are seeing in the log. You will only see one of these messages:

    sdr.hu registration: WORKED
    sdr.hu registration: ERROR (fields)
    sdr.hu registration: ERROR (your IP does not match URL, 1.2.3.4 != 5.6.7.8)
    sdr.hu registration: ERROR (apikey)
    sdr.hu registration: ERROR (sql-update)
    sdr.hu registration: FAILED n=NNN sp=XXX

    Which one are you seeing? Probably the one that says "your IP does not match URL". Please see this link for a description of the problem. The domain you are trying to use must resolve to the same IP address as the public address that the Kiwi uses to communicate with sdr.hu Ping your domain. Note the IP address. Then in the Kiwi log look for the line that says:

    Wed Dec 14 17:45:50 2016 0:00:05 ....      DDNS: public ip 103.26.16.225


    These IP addresses must be the same. How else would you expect your domain to resolve to the Kiwi's public IP address? The problem might be if you're trying to use some sort of IP proxy service where the IP addresses get translated. But that is not allowed by sdr.hu due to security restrictions. You can only do port mapping (e.g. what NAT does on your router) to map the public IP address of your Kiwi to whatever private IP address the Kiwi has behind your router. The quick start documentation explains this in detail.
  • All fixed now, after logging into beagle via root the ip address was different, changing the DNS setting on domain host sorted the issue.

    Thanks
  • Okay, good to hear. I'm sorry this seems to be headache for lots of people.

    I've got a new version about to go out that will display the log file in the "log" tab of the admin page. So you won't have to SSH into the Beagle to see what's going on.

    If you notice your Beagle's IP address is "changing" this might be your DHCP server assigning a different IP address over time which is not a good situation if your DNS or NAT settings are assuming a fixed address. The network section of the quick start documentation explains how to get your router to "lock" an IP address to the Beagle's MAC address instead of using DHCP. Or you can now assign a static IP address in the network tab of the admin page if that is more convenient.
  • I am having the same problem that MA3101SWL described:

    When ever I enter a url in the "Server domain name or IP address (e.g. kiwisdr.my_domain.com)" box and press enter or go into another box the domain resets back to "kiwisdr.example.com"

    He subsequently reported having fixed this issue, but I am stuck at this point.  I am using dyndns with this URL: 


    and it works for friends.  I am guessing I need to enter this in the Server Domain box:    w5uxh-kiwi.dyndns.org  but it does not "stick". Unfortunately this stuff is all black magic to me.  I have tried to understand this thread, but just can't get anything to stick in the Server Domain box.

    I do see that the LOG tab in the admin page now shows log messages but am guessing I need to get past my current roadblock before anything helpful might appear there (when I try to get my entry listed on sdr.hu).






    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 14.0px Menlo}
    span.s1 {font-variant-ligatures: no-common-ligatures}



  • jksjks
    edited December 2016
    Oh dear, this seems to be an actual bug. There is special code that removes any port specification that you might have added to the domain name entered in this field. Because if you want to change the port from the default 8073 it has to be done in a separate field on the network tab. So if you enter "my_kiwi.com:8073" here it gets automatically re-written to just "my_kiwi.com". But somehow this code broke at some point and now it doesn't let you change the field at all. 

    This will be fixed in the release going out this afternoon. Apologies for the problem.

  • No apology needed at all!  I am  amazed and pleased with your little Kiwi.
Sign In or Register to comment.