Is there an issue with the inactivity time limit? [fixed in v1.165]

I have the inactivity time limit set to 60 minutes. Despite that I often see users staying on the same frequency for many hours without being kicked by the inactivity timer. Last week I noticed one user staying for 15+ hours, an other one for 17+ hours, a third one for almost 19 hours and a forth one for 27+ hours without changing frequency, mode or zoom level. On the other hand, in the admin log, I can see that some users are kicked by the inactivity timer so it seems to work at least in some cases. Is there a way to monitor the behaviour of the inactivity timer? Perhaps some browsers manage to reset the timer automatically.

Regards

Mauritz / SM2BYC

Comments

  • those user logging has an issue in 1.156
  • This is probably not related with the admin/status issue as I still have problems with the inactivity timer in v1.162.
  • Accepted Answer
    I also have issues with the timer, I regularly see people 3-8+ hrs. I've a 2hr limit. I have to boot people off which are using it unfairly. 
  • Good to know. Then I'm not the only one with this issue.
  • jksjks
    Accepted Answer
    I'll have to add some clever debugging messages to try and figure this out. The trouble is I can't simply put a message in the log every time a user makes a frequency/mode change to help trace the problem. The log would just fill up the filesystem. I probably have to maintain a history of the last 10 changes with timestamps and then a button on the admin page to print it out. That's really the only way to differentiate a bug from the user willfully changing the freq/mode to reset the timer.

  • Yes, that sounds as a good way to sort this out. I assume that the 10 last changes must be stored separately for each of the four Rx channels as otherwise a single active user would fill all 10 memory positions.
  • jksjks
    Accepted Answer
    Meanwhile, why don't you try the separate 24 hour per-IP address time limit to control users? That uses a different mechanism which works as far as I know.

  • Yes, I have that activated since a couple of days with a 10 hour limit.
  • Accepted Answer
    Hi,

    Looks like my 15 min inactivity time out setting doesn't work either. I've had some users sitting on the same frequency for 2Hours + without any obvious signs of activity.

    I've had to set a 180 min per day per IP limit to try an curtail this as much as possible.

    Regards,

    Martin - G8JNJ
  • jksjks
    Accepted Answer
    Okay, bug has been found and will be fixed in today's update. A very unfortunate side-effect of an unrelated change made some time ago.

    Note when testing: as a convenience, connections from your local network are exempt from the inactivity and 24-hour timeouts. Look for a log message like "TLIMIT exempt local connection from 192.168.1.8". Same if you have given the exemption password with a local browser and it has been stored in a cookie.

    G8JNJ
  • Accepted Answer
    Great,

    Thanks John.

    Regards,

    Martin - G8JNJ


  • Thanks for the fix, appreciate the hard work with all the updates. Kiwi is a really fantastic SDR.
    WA2ZKD
Sign In or Register to comment.