Even after a reboot my Beagle CPU is only 1% idle and 99% busy [this is normal]

I have not had any GPS lock for a month or more and I just upgraded to v 1.155 and still have no GPS lock
But I suspect that problem is the result of no free CPU cycles.  This problem may have been present in previous versions, but I only now notice the CPU usage.
I can run 4 sessions, but I have to manually calibrate the ADC.

Comments

  • jksjks
    Accepted Answer
    No, 100% CPU use is normal. The code "busy waits" to meet real-time requirements.

  • So that busy cpu doesn't explain my lack of GPS tracking.  How can I diagnose GPS problems?
  • I may have to ship you a new unit. If it works then return old one for failure analysis.
  • edited January 7
    Upon further thought I am thinking of using my Bodar precision GPS clock to feed the Kiwi:  http://www.leobodnar.com/shop/index.php?main_page=product_info&cPath=107&products_id=234
    I bought it for my 2M WSPR beacon and it offers almost any output frequency at almost 10^-12 accuracy.
    From a picture of the PCB I can see three pads with the small pad connected by a surfaced trace to U403.  One of the large pads will be ground and the other ECLK.  From the NC7SZ125 datasheet, it appears that  the Bodnar output level is directly compatible with the NC7SZ125 input.
  • S/w changes required.
  • From the schematic it appears that all of the HW would not notice the change to an external clock.  I am a SW developer but not familiar with the github driven development environment.  Can you point me towards the SW which would need to be reworked?
  • No. FPGA must drive sig to disable osc and enable ext input buf. I can explain more in five days. Bad internet where im at, bad keyboard etc.
Sign In or Register to comment.